Contentful: How to resolve the problem with the strings not being sent to XTM Cloud for translation – duplicated files

Contentful: How to resolve the problem with the strings not being sent to XTM Cloud for translation – duplicated files

Introduction

Sometimes, you might report an issue where a translation project has been created in XTM Cloud but the strings have not actually been sent from Contentful.

Usually, the Last updated by column shows XTM Connect, indicating that the said string has successfully been sent off for translation in XTM Cloud; however, your name is still visible in that column instead.

Additionally, the following error might occur in the CMS UI:

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Root cause

In the vast majority of cases, the issue stems from the fact that the project created in XTM Cloud contains some duplicated files (exactly the same file names). They might have a different content, however the names of the entries are the same.

Since XTM Cloud does not allow for such a procedure, it adds suffixes for each one: _1, _2, _3.... Such files, however, were not found in the module saved in the database, because such files do not exist there. Therefore, Contentful does not recognize them, as they were not sent in the first place.


Solution

There are two solutions to this problem:

  1. Since the strings are sent as file names, it is enough to change their names or at least add some extra characters to differentiate those files.

  2. The second approach is to merge the files into one. This can be set up in the Contentful administrator panelSettings.

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